This page shows software and hardware requirements from two points of view:

  • For the Java developers who create games; and

  • For the users (your customers) who play the games that you created.

For Developers

These are the minimum requirements for developers who create games using the jMonkeyEngine SDK:

Operating systemMac OS X, Windows, Linux, Solaris

Memory (JVM heap size)

> 40 MB ++ memory for assets

CPU

> 1 GHz

Graphic card

AMD/ATI Radeon 9500, NVIDIA GeForce 5 FX, Intel GMA 4500, or better
supporting OpenGL 2.0 or better (native libraries are included in download)

Java Development Kit

JDK 6 or higher
Your development team gets the Java Development Kit for free from http://www.java.com; for Mac OS, see apple.com.
At least intermediate Java experience is required.

We recommend using the jMonkeyEngine SDK as game development environment (IDE). However, any third-party Java IDE (and even a text editor and the commandline) will work fine together with the jME framework if you are experienced with the tool of your choice. For requirements of other IDEs, please see the third party’s documentation.

For Users

These are the minimum requirements for your customers, users who play the games that were created using the jMonkeyEngine3 framework:

Operating systemMac OS X, Windows, Linux, Solaris

Memory (JVM heap size)

> 10 MB ++ memory for assets (models, textures, sounds, etc, of a particular game)

CPU

> 1 GHz

Graphic card

AMD/ATI Radeon 9500, NVIDIA GeForce 5 FX, Intel GMA 4500, or better
supporting OpenGL 2.0 or better (native libraries are included in download)

(For mobile games only) Android 2.2 OS, graphics card supporting OpenGL 2

Java Runtime

Java 5 or higher
The Java Virtual Machine (JVM) is required to run jME games.
The JVM is often preinstalled, if not, your users get it for free from http://www.java.com; for Mac OS, see apple.com.

Make sure to inform your users about these requirements.